Video verification / Videolegitimierung
Incident Report for Bitwala
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 10:00 CEST
Update
We are continuing to monitor for any further issues.
Posted May 18, 2020 - 16:29 CEST
Monitoring
EN:
Wait times with our verification partner, IDNow, are currently longer than usual. Due to COVID-19 related measures and a spike in call volume IDnow’s availability is stretched.

Our apologies for the inconvenience as we work with our partner to keep everyone safe and healthy in these unprecedented times.

DE:
Die Wartezeiten bei unserem Verifizierungspartner, IDNow, sind derzeit deutlich länger als üblich. Aufgrund von Maßnahmen im Zusammenhang mit COVID-19 und einem Anstieg des Callvolumens ist aktuell die Erreichbarkeit beeinträchtigt.

Wir entschuldigen uns für die Unannehmlichkeiten, während wir bemühen mit unserem Partner, in diesen ungewissen Zeiten für die Sicherheit und Gesundheit aller Mitarbeiter zu sorgen.
Posted Mar 28, 2020 - 12:11 CET
This incident affected: Onboarding.