Website Unavailable/ Webseite nicht erreichbar
Incident Report for Bitwala
Resolved
This incident has been resolved.
Posted Apr 08, 2021 - 10:52 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2021 - 10:40 CEST
Identified
Our website is currently not available. We are working on bringing it back as soon as possible. In the meantime, please login to your account using the mobile Bitwala app.

Unsere Webseite ist momentan nicht erreichbar. Wir arbeiten an der Wiederherstellung. In der Zwischenzeit kannst du dein Konto über die mobile Bitwala App erreichen.
Posted Apr 08, 2021 - 09:48 CEST